NAP6官方旗舰店
搜索
发新帖
午饭无线 推广广告R7800 完胜 华硕路由器NETGEAR Vs ASUS T-Mobile定制版NETGEAR团购
开启左侧

地址解析协议 ARP 操作路径:/ip arp

[复制链接]
998 0

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
地址解析协议 ARP

操作路径:/ip arp

每个主机通过 IP 地址通信,但同一子网的设备,通过 MAC 地址进行数据交换,三层通信建立在二层的基础上,地址解析协 议用于 OSI 第三层解析第二层的 IP 和 MAC。 一个路由器会有一个当前 ARP 列表,同一子网通信通常是建立为动态 ARP 列表,但为增强网络稳定性和安全性,可建立静态 ARP 列表,如防御 ARP 病毒。

属性描述

address (IP 地址) – 对应的 IP 地址

interface (名称) – 被分配 IP 地址的接口名称

mac-address (MAC 地址; 默认: 00:00:00:00:00:00) – 相应的 MAC 地址

注:最大的 ARP 的登记数为 8192.

如果 ARP 功能在接口上被关闭,例如:使用 arp=disabled,来至客户端的 ARP 请求将不被路由器回应,因此必须添加 静态的 ARP 才行。 例如,通过 arp 命令将路由器的 IP 和 MAC 地址必须添加到 windows 工作站中:

C:\> arp -s 10.5.8.254 00-aa-00-62-c6-09

如果在接口上的 arp 属性设置为 reply-only,这时路由器只应答来至静态 ARP 的请求。邻近的 MAC 地址将通过/ip arp设置唯一的静态 ARP 列表。

例如:
  1. [RouterOS@ROSABC] ip arp> add address=10.10.10.10 interface=ether2 mac-address=06:21:00:56:00:12

  2. [RouterOS@ROSABC] ip arp> print
  3. Flags: X - disabled, I - invalid, H - DHCP, D - dynamic
  4. # ADDRESS MAC-ADDRESS INTERFACE
  5. 0 D 2.2.2.2 00:30:4F:1B:B39 ether2
  6. 1 D 10.5.7.242 00:A0:24:9D:52:A4 ether1
  7. 2 10.10.10.10 06:21:00:56:00:12 ether2
  8. [RouterOS@ROSABC] ip arp>
复制代码


如果在一个接口上使用静态 ARP 记录会使网络更安全,你必须将该接口上的 arp 设置为 'reply-only' ,相关操作在下面的

/interface 目录中:
  1. [RouterOS@ROSABC] ip arp> /interface ethernet set ether2 arp=reply-only

  2. [RouterOS@ROSABC] ip arp> print
  3. Flags: X - disabled, I - invalid, H - DHCP, D - dynamic
  4. # ADDRESS MAC-ADDRESS INTERFACE
  5. 0 D 10.5.7.242 00:A0:24:9D:52:A4 ether1
  6. 1 10.10.10.10 06:21:00:56:00:12 ether2

  7. [RouterOS@ROSABC] ip arp>
复制代码




您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表