NAP6官方旗舰店
搜索
发新帖
NETGEAR R7500v2NETGEAR Vs ASUS T-Mobile定制版NETGEAR团购
开启左侧

MikroTik RouterOS Bridge 桥接配置教程

[复制链接]
2243 0

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
桥接(Bridge),是工作在OSI网络模型的第二层链路层,对网络数据包进行转发的过程。简单的说就是通过网桥可以把两个不同的物理局域网连接起来,是一种在链路层实现局域网互连的存储转发设备。

RouterOS支持以太网MAC层桥接,如以太网卡、EoIP(Ethernet over IP)、WLAN协议和PPP协议等,还支持桥接的防火墙过滤功能,能有效对二层网络MAC和协议进行控制管理。

Bridge主要特征:
生成树协议(STP)
快速生成树协议(RSTP)
支持多网桥接口
MAC地址可以被实时监控
为三层访问分配IP地址
支持基于桥数据包过滤器

功能包: system
等级: Level3
操作路径: /interface bridge

在RouterOS的bridge能实现以太网二层交换的功能外,还能实现WLAN的桥接和WDS的MESH组网等,还能实现虚拟接口类以太网的交换网络,如EoIP(Ethernet over IP)、PPP tunnel bridging protocol (BCP)

网桥在功能上和交换机同样的网络设备,除了连接两个二层网络基本功能外,RouterOS网桥还具备防火墙过滤和STP/RSTP,STP(Spanning Tree Protocol)生成树协议,逻辑上断开环路,防止二层网络的广播风暴的产生。在复杂的网络拓扑出现(有意或无意)。如果没有特殊的处理,环路将造成网络无法正常工作,因为环路会导致雪崩一样的广播数据包倍增。RSTP(rapid spanning tree protocol)则是快速生成树协议收敛时间更短。生成树协议不仅能避免环路造成的广播风暴导致网络无法正常工作,还可以建立一个冗余的二层环网络,实现设备的冗余保护。

注:关于无线的RSTP MESH请参阅《RouterOS wireless无线教程v6》

Bridge配置

通过将多个局域网络连接到一个网桥上,实现多个局域网直接的MAC层数据转发,类似与交换机的功能,即学习、存储和转发的功能,在host列表中可以看到各个接口学习到的MAC地址,并存储在bridge中用于查找需要通信的MAC地址。

属性描述
ageing-time (时间; 默认: 5m) - 一个主机信息可以被保存在桥数据库的时间
arp (disabled | enabled | proxy-arp | reply-only; 默认: enabled) - 地址解析协议设置
forward-delay (时间; 默认: 15s) - 在桥接口初始化阶段(例如:在路由器启动或起用接口之后)桥正常工作之前监听/学习状态所用的时间
garbage-collection-interval (时间; 默认: 4s) - 丢弃桥数据库中老的(过期的)主机词条的频率。无用存储单元收集过程消除比ageing-time属性定义的更老的词条。
hello-time (时间; 默认: 2s) - 给其他桥发送hello包的频率
mac-address (只读: MAC地址) – 接口的MAC地址
max-message-age (时间; 默认: 20s) - 保留从其他桥接受hello信息的时间长短
mtu (整型; 默认: 1500) - 最大传输单元
name (名称; 默认: bridgeN) - 桥接口的描述性名称
priority (整型: 0..65535; 默认: 32768) - 桥接口优先级。STP使用优先级参数决定如果最后两个端口形成了环路应保留哪个
stp (no | yes; 默认: no) - 是否启用生成树协议。桥环路仅在这个属性启用是才会被阻止。
rstp (no | yes; 默认: no) - 是否启用快速生成树协议。


把接口ether1和ether2放在一个桥里:

1.        添加一个桥接口,命名为MyBridge:

  1. /interface bridge add name="MyBridge" disabled=no
复制代码

2.        把ether1和ether2添加到MyBridge接口:

  1. /interface bridge port add interface=ether1 bridge=MyBridge
  2. /interface bridge port add interface=ether2 bridge=MyBridge
复制代码

Bridge setting

这个参数可以选择是否启用ip firewall的三层过滤规则,这个功能有别于2.9的桥接功能,如果关闭三层的ip firewall过滤,可以大大提高RouterOS的网桥转发率,特别在WLAN桥接和一些纯二层的网桥应用中非常有用。

当你需要开启三层的网桥过滤时,包括ip firewall filter、mangle、nat和queue流控等,就需要打开以下设置。
  1. [admin@MikroTik] /interface bridge settings>set use-ip-firewall=yes
  2. [admin@MikroTik] /interface bridge settings>print
  3.                     use-ip-firewall: yes
  4.      use-ip-firewall-for-vlan: no
  5.   use-ip-firewall-for-pppoe: no
  6. [admin@MikroTik] /interface bridge settings>
复制代码

当然网桥由于打开了三层过滤,转发率会受到一定的影响,但你可以实现对三层数据的过滤和流控。通过启用三层过滤我们可以实现许多透明桥的流量整形,如IP地址流控、P2P和基于80端口的HTTP流控等;也可以实现基于IP和协议端口的过滤。

注意:如果桥接的网络中通过的是vlan封装,即tagg,即两端交互设备使用trunk模式,请选择use-ip-firewall-for-vlan,这样才能在ip firewall对vlan中的数据包进行处理,如果通过是pppoe协议选择use-ip-firewall-for-pppoe

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

精彩推荐

热点动态

精彩图文

快速回复 返回顶部 返回列表