NAP6官方旗舰店
搜索
发新帖
午饭无线 推广广告R7800 完胜 华硕路由器NETGEAR Vs ASUS T-Mobile定制版NETGEAR团购
开启左侧

MikroTik RouterOS APR指令介绍

[复制链接]
1143 0

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
每个主机通过IP地址通信,但局域网的设备,通过MAC地址进行数据交换,三层通信建立在二层的基础上,地址解析协议ARP用于OSI第三层与第二层的IP和MAC连接。一个路由器会有一个当前ARP列表,同一子网通信通常是建立为动态ARP列表,但为增强网络稳定性和安全性,可建立静态ARP列表,如防御ARP病毒。

需要功能包:system
需要等级:Level1
操作路径:/ip arp

属性描述
address (IP 地址) – 对应的IP地址
interface (名称) – 被分配IP地址的接口名称
mac-address (MAC地址; 默认: 00:00:00:00:00:00) – 相应的MAC地址

注:最大的ARP的条目数为8192,所以在同一广播域内主机数量被限制在8192台。
如果ARP功能在接口上被关闭,例如:使用arp=disabled,来至客户端的ARP请求将不被路由器回应,因此必须添加静态的ARP才行。 例如,通过arp 命令将路由器的IP和MAC地址必须添加到windows工作站中:

  1. C:\> arp -s 10.5.8.254  00-aa-00-62-c6-09
复制代码

如果在接口上的arp属性设置为reply-only,这时路由器只应答来至静态ARP的请求,即对ARP列表中的静态ARP条目进行匹配。

例如:添加静态的IP与ARP条目
  1. [admin@MikroTik] ip arp> add address=10.10.10.10 interface=ether2 mac-address=06:21:00:56:00:12
  2. [admin@MikroTik] ip arp> print
  3. Flags: X - disabled, I - invalid, H - DHCP, D - dynamic
  4.   #   ADDRESS         MAC-ADDRESS       INTERFACE
  5.   0 D 2.2.2.2              00:30:4F:1B:B3:D9    ether2
  6.   1 D 10.5.7.242       00:A0:24:9D:52:A4    ether1
  7.   2     10.10.10.10     06:21:00:56:00:12     ether2

  8. [admin@MikroTik] ip arp>
复制代码


如果在一个接口上使用静态ARP记录会使网络更安全,即我们常说的路由器ARP绑定,除了配置静态ARP条目,还必须将该接口上的arp设置为 'reply-only',相关操作在下面的/interface目录中,如果非静态的ARP条目,将无法与路由器进行通信:

  1. [admin@MikroTik] ip arp> /interface ethernet set ether2 arp=reply-only
  2. [admin@MikroTik] ip arp> print
  3. Flags: X - disabled, I - invalid, H - DHCP, D - dynamic
  4.   #   ADDRESS         MAC-ADDRESS       INTERFACE
  5.   0 D 10.5.7.242       00:A0:24:9D:52:A4    ether1
  6.   1     10.10.10.10     06:21:00:56:00:12     ether2

  7. [admin@MikroTik] ip arp>
复制代码


您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

精彩推荐

热点动态

精彩图文

快速回复 返回顶部 返回列表