NAP6官方旗舰店
搜索
发新帖
午饭无线 推广广告R7800 完胜 华硕路由器NETGEAR Vs ASUS T-Mobile定制版NETGEAR团购
开启左侧

MikroTik RouterOS备份与复位管理

[复制链接]
1958 0

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
RouterOS可以通过backup下的save命令将系统备份为二进制文件,采用FTP访问或在winbox中的file列表中下载备份文件,并可以通过备份文件恢复路由器设置。
RouterOS通过export命令导出配置文件,可生成文本文件(可编辑脚本),同样使用FTP或通过在winbox中的file中下载文件,导入配置则将脚本文本文件导入路由器。
reset-configuration系统复位命令将所有的配置信息从RouterOS中全部删除掉,在做此操作前,最好先将路由器的配置备份一次。

注:为了保证备份不会失败,请在将备份的文件恢复到同样的软件版本和同样的硬件配置上去.

系统备份与恢复

操纵路径:/system backup

Save指令是保存当前配置到一个备份文件中,显示文件在/file目录中。如需要回复指定的备份文件,可通过/system backup中的load指令载入配置,还原当前备份文件的配置。
指令描述:

load name=[filename] – 载入备份文件的配置
save name=[filename] – 保存当前的配置到文件中

例如:将当前的配置保存到文件test:
  1. [admin@MikroTik] system backup> save name=test
  2. Saving system configuration
  3. Configuration backup saved
  4. [admin@MikroTik] system backup>
复制代码

在路由器中查看保存的文件:
  1. [admin@MikroTik] > file print
  2.   # NAME                           TYPE         SIZE       CREATION-TIME
  3.   0 test.backup                    backup       12567      aug/12/2002 21:07:50
  4. [admin@MikroTik] >
复制代码

导入备份文件test:
  1. [admin@MikroTik] system backup> load name=test
  2. Restore and reboot? [y/N]: y
  3. ...
复制代码

Winbox下配置直接在files菜单下,通过backup和restore操作
1.png

导出指令(Export)

指令名称:export

Export指令用于导出脚本配置信息,这个命令可以在任何目录下执行。export 同样也可以通过file属性指定保存的文件名,可用FTP或者进入winbox下载。export导出的文件是明文,且是标准的RouterOS脚本,所以可以并进行编辑。

指令描述:

hid-sensitive – 隐藏敏感参数,如密码等信息。
file=[filename] – 保存的文件名称。

例如:
  1. [admin@MikroTik] > ip address print
  2. Flags: X - disabled, I - invalid, D - dynamic
  3. #   ADDRESS            NETWORK         BROADCAST       INTERFACE
  4. 0   10.1.0.172/24      10.1.0.0        10.1.0.255      bridge1
  5. 1   10.5.1.1/24        10.5.1.0        10.5.1.255      ether1
  6. [admin@MikroTik] >
复制代码

导出一个脚本文件,该文件包含了IP地址配置参数:
  1. [admin@MikroTik] ip address> export file=address
  2. [admin@MikroTik] ip address>
复制代码

在路由器中查看导出的文件:
  1. [admin@MikroTik] > file print
  2. # NAME                            TYPE         SIZE       CREATION-TIME
  3. 0  address.rsc                     script       315        dec/23/2003 13:21:48
  4. [admin@MikroTik] >
复制代码

RouterOS 5.12新增功能export compact命令,该命令简化了导出的参数,仅导出修改的配置,系统默认配置参数将不再被一并导出。有助于对比路由器的配置和方便导入其他路由器。
  1. [admin@MikroTik] > export compact
  2. # jan/02/2012 01:57:23 by RouterOS 5.12
  3. #
  4. /ip pool
  5. add name=dhcp_pool1 ranges=10.1.0.2-10.1.0.254
  6. /ip dhcp-server
  7. add address-pool=dhcp_pool1 disabled=no interface=ether3 name=dhcp1
  8. /ip address
  9. add address=10.1.0.1/24 interface=ether3
  10. /ip dhcp-client
  11. add disabled=no interface=ether1
  12. /ip dhcp-server network
  13. add address=10.1.0.0/24 gateway=10.1.0.1
  14. /ip dns
  15. set allow-remote-requests=yes max-udp-packet-size=512 servers=10.5.8.1
  16. /ip firewall nat
  17. add action=masquerade chain=srcnat out-interface=ether1
  18. /ip smb shares
  19. set [ find default=yes ] directory=/pub
  20. /system ntp client
  21. set primary-ntp=10.1.1.1 secondary-ntp=10.1.1.2
  22. /system routerboard settings
  23. set cpu-frequency=266MHz
  24. /tool bandwidth-server
  25. set authenticate=no
  26. [admin@MikroTik] >
复制代码

6.0版本后对export做了新的调整

export compact命令被取消,当使用export命令时,直接导出基本配置,系统默认配置参数将不再被一并导出。如果需要导出详细的配置可以使用verbose
/export verbose file=myConfig

导入指令(Improt)

操作路径:/import

import命令只能在根目录下使用/import file_name指令还原指定配置。这种方式适用于部分配置或者功能。

指令描述:

file=[filename] – 导入的路由器配置文件

例如使用下面的指令操作导入配置文件:
  1. [admin@MikroTik] > import address.rsc
  2. Opening script file address.rsc
  3. Script file loaded successfully
  4. [admin@MikroTik] >
复制代码

Winbox里可以查看生产的.rsc的文件:
2.png

系统复位

操作路径:/system> reset-configuration

这个指令将会清除掉路由器的所有配置,包括登陆的账号和密码(恢复为“admin“和空密码)IP地址和其他配置将会被抹去,在reset指令执行后路由器将会重启。RouterOS v3.x后版本,在复位后ether1接口会配置默认IP地址192.168.88.1/24

例如:
  1. [admin@Office] /system> reset-configuration
  2. Dangerous! Reset anyway? [y/N]: y
复制代码

复位时你在命令后也可以带相关参数,如下:
  1. [admin@MikroTik] /system> reset-configuration
  2. keep-users  no-defaults  run-after-reset  skip-backup
复制代码

复位时可带keep-users指令,描述如下:

Keep-users – 复位不删除管理用户账号


您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

精彩推荐

热点动态

精彩图文

快速回复 返回顶部 返回列表