NAP6官方旗舰店
搜索
发新帖
午饭无线 推广广告R7800 完胜 华硕路由器NETGEAR Vs ASUS T-Mobile定制版NETGEAR团购
开启左侧

MikroTik RouterOS Simple Queue介绍

[复制链接]
1249 0

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
Simple queue简单队列是IP地址或子网段进行流量限制,IP限流最简单方法就是使用/queue simple。也可以用simple queue建立高级QoS应用,如mangle标记和等级队列。

功能包:system
等级: Level 3
操作路径: /queue simple

在/queue simple创建一个流控配置项目,会分别有三个独立的队列,分别是 global-in, global-out和 global-total. 如果在/queue simple创建一个默认队列规则(无流控限制、queue type为默认),并且该队列没有子队列,即这样的队列实际上没有创建。如果队列只配置了upload/download流控属性,global-total队列可以被忽略。如果仔细观察,当建立一条queue simple规则同时在queue tree可以瞬间看到3条规则的建立,然后被隐藏到后台,即queue simple被建立在queue tree下。

Simple queues是有序对队列即FIFO,每个数据包都必须经过每一个队列处理,直到最后一条队列规则,即如果有1000条队列,匹配的队列规则是排列在第1000条,那么数据包过经过前面999条后,才能到达该规则。 因此Simple queue在出现大量队列规则后,处理效率会降低。

在v6大改动后,simple queue已经具备了和queue tree相同的等级流控功能。在v6前simple queue使用的是FIFO算法,后v6之后FIFO算法已经取消,优化了RouterOS在流控处理性能。

•        P2P流量队列
•        计划时间任务执行队列规则
•        优先级队列
•        从 /ip firewall mangle 使用多重包标记
•        双向流控(对上行和下行的带宽限制)

应用举例
下面假设我们想要对网络192.168.0.0/24流量限制为:下行1Mb上行512kb,这里我们需要让服务器192.168.0.1不受流量控制。网络的基本设置如图:
Simple Queue.png

这里我们使用(simple queue)简单队列,首先我们配置RouterOS的IP地址、网关和NAT等基本网络参数:

  1. [admin@MikroTik] ip address> print
  2. Flags: X – disabled, I – invalid, D - dynamic
  3. #   ADDRESS            NETWORK         BROADCAST       INTERFACE
  4. 0   192.168.0.254/24    192.168.0.0     192.168.0.255      Local
  5. 1   10.5.8.104/24           10.5.8.0            10.5.8.255             Public
  6. [admin@MikroTik] ip address>
复制代码

路由配置:
  1. [admin@MikroTik] ip route> print
  2. Flags: X – disabled, A – active, D – dynamic,
  3. C – connect, S – static, r – rip, b – bgp, o - ospf
  4. #     DST-ADDRESS        G GATEWAY        DISTANCE   INTERFACE
  5. 0 ADC 10.5.8.0/24                                                                   Public
  6. 1 ADC 192.168.0.0/24                                                            Local
  7. 2 A S 0.0.0.0/0                   r 10.5.8.1                                      Public
  8. [admin@MikroTik] ip route>
复制代码

最后不要忘记在ip firewall nat中配置src-nat的伪装或nat,做地址转换操作。

为网络192.168.0.0/24的所有客户端添加一个限制下载流量为2Mb上传流量1Mb的简单队列规则。

  1. [admin@MikroTik] queue simple> add name=Limit-Local target-address=192.168.0.0/24 max-limit=1000000/2000000
  2. [admin@MikroTik] queue simple> print
  3. Flags: X - disabled, I - invalid, D - dynamic
  4. 0    name="Limit-Local" target-addresses=192.168.0.0/24 dst-address=0.0.0.0/0
  5.       parent=none priority=8 queue=default/default  limit-at=0/0 max-limit=1000000/2000000 total-queue=default
  6. [admin@MikroTik] queue simple>
复制代码

max-limit限制了最大可用带宽,从客户的角度看,参数target-addresses定义限制带宽的目标网络或者主机(也可以用逗号分隔开网络段或主机地址)。
这里不想让服务器受到我们添加上面规则的任何流量限制,我们可以通过添加一个没有任何限制的规则(max-limit=0/0代表没有任何限制)并把它移到列表的顶部:

  1. [admin@MikroTik] queue simple> add name=Server target-addresses=192.168.0.1/32
  2. [admin@MikroTik] queue simple> print
  3. Flags: X - disabled, I - invalid, D - dynamic
  4. 0    name="Limit-Local" target-addresses=192.168.0.0/24 dst-address=0.0.0.0/0
  5.       parent=none priority=8 queue=default/default limit-at=0/0 max-limit=65536/131072 total-queue=default

  6. 1    name="Server" target-addresses=192.168.0.1/32 dst-address=0.0.0.0/0
  7.       parent=none priority=8 queue=default/default limit-at=0/0 max-limit=0/0       total-queue=default
复制代码

使用move命令将第二条规则移动到第一条,即从编号1,移动到编号0,用于queue simple中FIFO的优先顺序(注意:v6.0后FIFO算法被取消,所以不存在move命令)

  1. [admin@MikroTik] queue simple> move 1 0
  2. [admin@MikroTik] queue simple> print
  3. Flags: X - disabled, I - invalid, D - dynamic
  4. 0    name="Server" target-addresses=192.168.0.1/32 dst-address=0.0.0.0/0
  5.       parent=none priority=8 queue=default/default
  6.       limit-at=0/0 max-limit=0/0 total-queue=default

  7. 1    name="Limit-Local" target-addresses=192.168.0.0/24 dst-address=0.0.0.0/0
  8.       parent=none priority=8 queue=default/default
  9.       limit-at=0/0 max-limit=65536/131072 total-queue=default
  10. [admin@MikroTik] queue simple>
复制代码


您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表