NAP6官方旗舰店
搜索
发新帖
午饭无线 推广广告R7800 完胜 华硕路由器NETGEAR Vs ASUS T-Mobile定制版NETGEAR团购
开启左侧

MikroTik RouterOS常用配置命令大全

[复制链接]
1344 0

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
MikroTik RouterOS是一种路由操作系统,是基于Linux核心开发,兼容x86 PC的路由软件,并通过该软件将标准的PC电脑变成专业路由器,在软件RouterOS 软路由图的开发和应用上不断的更新和发展,软件经历了多次更新和改进,使其功能在不断增强和完善。特别在无线、认证、策略路由、带宽控制和防火墙过滤等功能上有着非常突出的功能,其极高的性价比,受到许多网络人士的青睐。
1、路由版本
  1. # mar/09/1970 09:10:50 by RouterOS 6.23
复制代码
2、以太网接口
  1. #以太网口重命名
  2. /interface ethernet
  3. set [ find default-name=ether1 ] name=ether01
  4. set [ find default-name=ether2 ] name=ether02
  5. set [ find default-name=ether3 ] name=ether03
  6. set [ find default-name=ether4 ] name=ether04
  7. set [ find default-name=ether5 ] name=ether05
  8. set [ find default-name=ether6 ] name=ether06
  9. set [ find default-name=ether7 ] name=ether07
  10. set [ find default-name=ether8 ] name=ether08
  11. set [ find default-name=ether9 ] name=ether09
  12. set [ find default-name=ether10 ] name=ether10
复制代码
3、网桥配置
  1. #配置网桥
  2. /interface bridge
  3. add name=bridge01
  4. #网桥成员(多个以太网端口)
  5. /interface bridge port
  6. add bridge=bridge01 interface=ether06
  7. add bridge=bridge01 interface=ether07
  8. add bridge=bridge01 interface=ether08
  9. add bridge=bridge01 interface=ether09
  10. add bridge=bridge01 interface=ether10
复制代码
4、内网接口配置
  1. /ip address
  2. #内网接口IP配置
  3. add address=10.0.0.1/24 interface=bridge01 network=10.0.0.0
复制代码
5、源地址NAT
把内网的源主机伪装成具有当前公网IP的主机与外网通讯
  1. /ip firewall nat
  2. #使用PPPOE的配置方法
  3. add action=masquerade chain=srcnat out-interface=all-ppp
  4. #使用静态IP的配置方法
  5. add action=masquerade chain=srcnat out-interface=ether01
复制代码
6、DHCP相关配置
  1. #DHCP范围
  2. /ip pool
  3. add name=default-dhcp ranges=10.0.0.50-10.0.0.199
  4. #DHCP服务
  5. /ip dhcp-server
  6. add address-pool=default-dhcp disabled=no interface=bridge01 name=dhcp1
  7. #DHCP服务网络
  8. /ip dhcp-server network
  9. add address=10.168.0.0/24 comment="default configuration" dns-server=\
  10.     202.96.128.86,202.96.128.166 gateway=10.168.0.1 netmask=24
  11. #DHCP客户端网络参数指定
  12. /ip dhcp-server network
  13. add address=10.0.0.0/24 comment="default configuration" dns-server=202.96.128.86,202.96.128.166 gateway=10.0.0.1
  14. #本机作为DHCP客户端的配置
  15. /ip dhcp-client
  16. add comment="default configuration" dhcp-options=hostname,clientid interface=ether01
复制代码

7、外网口配置
  1. #PPPOE拨号配置
  2. /interface pppoe-client
  3. add ac-name="" add-default-route=yes allow=pap,chap,mschap1,mschap2 \
  4.     default-route-distance=1 dial-on-demand=yes disabled=no interface=ether01 \
  5.     keepalive-timeout=60 max-mru=1480 max-mtu=1480 mrru=disabled name=\
  6.     ChinaNet password=******* profile=default service-name="" use-peer-dns=\
  7.     no user=0769*******@163.gd
  8. /ip address
  9. #外网接口静态IP配置
  10. add interface=ether01 address=192.168.1.64
复制代码
8、默认路由配置
  1. #外网接口为固定IP地址使用
  2. /ip route
  3. add dst-address=0.0.0.0/0 gateway=192.168.1.1
复制代码
9、目标地址NAT(端口映射)
把内网的目标主机伪装成具有当前公网IP的主机与外网通讯
  1. /ip firewall nat
  2. #使用PPPOE的配置方法
  3. add action=dst-nat chain=dstnat dst-port=8080 in-interface=all-ppp protocol=tcp to-addresses=10.0.0.200 to-ports=8080
  4. #使用静态IP的配置方法
  5. add action=dst-nat chain=dstnat dst-port=8080 in-interface=ether01 protocol=tcp to-addresses=10.0.0.200 to-ports=8080
复制代码
10、防火墙配置
10.1、地址列表
  1. /ip firewall address-list
  2. add list=10.0.0.0/24 address=10.0.0.2-10.0.0.254
复制代码
10.2、filter
10.2.1、基础配置代码
  1. /ip firewall filter
  2. #--允许icmp协议(ping)的数据包进入所有接口
  3. add chain=input action=accept protocol=icmp
  4. #--允许已经建立连接状态的数据包进入所有接口
  5. add chain=input action=accept connection-state=established
  6. add chain=input action=accept connection-state=related
  7. #--拒接所有(TCP/UDP等)数据包进入all-ppp接口(如果固定IP接口使用ether01)
  8. add chain=input action=drop in-interface=all-ppp
  9. #--允许已经建立连接状态的数据包内核转发
  10. add chain=forward action=accept connection-state=established
  11. add chain=forward action=accept connection-state=related
  12. #--拒绝无效状态的数据包内核转发
  13. add chain=forward action=drop connection-state=invalid
复制代码
10.2.2、允许端口访问
  1. #--允许目标端口是8080/tcp的数据包进入all-ppp接口
  2. #PPPOE配置方法
  3. add chain=input dst-port=8080 in-interface=all-ppp protocol=tcp
  4. #静态IP的配置方法
  5. add chain=input dst-port=8080 in-interface=ether01 protocol=tcp
复制代码
10.2.3、数据包过滤
  1. /ip firewall filter
  2. add chain=forward action=accept protocol=tcp in-interface=bridge01 dst-port=53
  3. add chain=forward action=accept protocol=udp in-interface=bridge01 dst-port=53
  4. add chain=forward action=accept protocol=tcp in-interface=bridge01 dst-port=80
  5. add chain=forward action=accept protocol=tcp in-interface=bridge01 dst-port=443
  6. add chain=forward action=drop in-interface=bridge01
复制代码
11、NTP服务器与时区设置:
  1. /system ntp client set enabled=yes server-dns-names=1.centos.pool.ntp.org
  2. /system clock set time-zone-name=Asia/Shanghai
复制代码
12、其他配置
  1. #邻居发现协议(默认值)
  2. /ip neighbor discovery
  3. set ether01 discover=no
  4. #管理端口
  5. /port
  6. set 0 name=serial0
  7. #DNS服务器配置
  8. /ip dns
  9. set allow-remote-requests=yes servers=202.96.128.86,202.96.128.166
  10. #服务配置
  11. /ip service
  12. set telnet disabled=yes
  13. /lcd
  14. set time-interval=daily
  15. /tool mac-server
  16. set [ find default=yes ] disabled=yes
  17. add interface=ether02
  18. add interface=ether03
  19. add interface=ether04
  20. add interface=ether05
  21. add interface=ether06
  22. add interface=ether07
  23. add interface=ether08
  24. add interface=ether09
  25. add interface=ether10
  26. add interface=sfp1
  27. add
  28. /tool mac-server mac-winbox
  29. set [ find default=yes ] disabled=yes
  30. add interface=ether02
  31. add interface=ether03
  32. add interface=ether04
  33. add interface=ether05
  34. add interface=ether06
  35. add interface=ether07
  36. add interface=ether08
  37. add interface=ether09
  38. add interface=ether10
  39. add interface=sfp1
  40. add
复制代码
13、备注
每秒位115200


您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表